linuxsir首页 LinuxSir.Org | Linux、BSD、Solaris、Unix | 开源传万世,因有我参与欢迎您!
网站首页 | 设为首页 | 加入收藏
您所在的位置:主页 > Linux发行版Archlinux >

Ghostscript 远程代码执行漏洞(CVE-2016-7979)

时间:2017-02-20  来源:未知  作者:linuxsir首页
Ghostscript 远程代码执行漏洞(CVE-2016-7979)


发布日期:2017-01-13
更新日期:2017-02-15

受影响系统:

Ghostscript Ghostscript

描述:


BUGTRAQ  ID: 95337
CVE(CAN) ID: CVE-2016-7979

Ghostscript是PostScript语言和PDF的解释程序。

ghostscript未验证函数initialize_dsc_parser的参数,存在类型混淆漏洞,构造的postscript文档,可造成在gs进程上下文中执行任意代码。

<*来源:Tavis Ormandy (taviso@gentoo.org)
  *>

建议:


厂商补丁:

Ghostscript
-----------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://ghostscript.com/download/

友情链接